Transducer problems

Hophead

I've posted enough I should edit this section
Jun 26, 2004
224
191
san diego
Name
ryan
Boat
22’ Seaway
In the last few trips we’ve had issues with interference. Equipment is lowrance hds 12 gen 3 with airmar B75M. Have had the transducer for just over a year. We lose the bottom in 200’ or less, and experience a lot of inference at 5 knots or more. Bottom is clear in slip at marina, but last trip offshore I dropped jigs under boat, and no visual on screen.

Today we tested noise in our electrical system, specifically the sonar pin connector, and found very little. I’ve read airmar makes a transducer tester TDT 1000, but this sounds like an expensive piece of equipment and would only be justified by a marine electronic specialist. Does anyone know someone qualified to help me determine my problem?

I haven’t dove under the boat, but I would hope my diver cleaning the boat every three weeks would keep the transducer clean. I also spoke to airmar and they feel it could be cavitation, but the unit worked fine for months and now has issues.

Thanks in advance for any useful feedback.
 
  • Like
Reactions: clevel

pescaloco

fish hunter
Aug 17, 2005
990
171
san diego
Name
Mark B.
Boat
27 Foot Stringari Custom
Call Honor marine
They have a transducer tester and good techs
 

MATTANZA

old man of the sea, in training.
Aug 23, 2004
5,205
2,588
Cali the state of confusion, the state of shock
Name
RICK
Boat
Boston Whaler 25' Outrage "MATTANZA II", 34' Radovcich "AMY ANNE" {when it needs to be fixed}
if you can , run the power directly to your battery , and run your transducer cable directly to the unit away from all other wires. then check it.
 

scotte24

Newbie
Feb 11, 2007
7
3
ojai
Name
scott
Boat
Davis
I had a similar issue after installing my B75M, turned out to be getting interference from the Magnetic drive bait pump.