Steering issues

Discussion in 'Boating Discussion' started by mandoman68, May 15, 2009.

Thread Status:
Not open for further replies.
  1. mandoman68

    mandoman68 Big Loco

    Location:
    Aztlan
    Name:
    Mandoman
    Boat:
    Kathleen
    • Messages:
      (627)
    • Likes Received:
      (215)
    Replaced my old manual steering last spring because it was hard to turn. Worked great for about 10 months. Steering hard to turn again. I lubed the shaft(no jokes please) regularly. I have an old 71 Glastron.Any suggestions would be appreciated.:_diarrhea_:
     
  2. tuna taxi

    tuna taxi Well-Known "Member"

    Location:
    90650
    Name:
    Jorge
    Boat:
    20' Skipjack
    • Messages:
      (1,736)
    • Likes Received:
      (89)

    That's like asking, 'No responses please'.

    goodluck!!
     
  3. mandoman68

    mandoman68 Big Loco

    Location:
    Aztlan
    Name:
    Mandoman
    Boat:
    Kathleen
    • Messages:
      (627)
    • Likes Received:
      (215)
    The whole sentence was a joke you dildo.(lube the shaft,hello?) Sounds like you need more help than I do, dork. You really should think before you attempt to be funny.I take it you know even less about boat repair,huh Einstein? That's a rhetorical question, Pendejo? Run Forest Run? What a Moron.ONLY MECHANICALLY INCLINED COMEDIANS PLEASE!
     
  4. ALUMINATOR

    ALUMINATOR Well-Known "Member"

    Location:
    North San Diego County
    Name:
    Dennis
    Boat:
    27' self built
    • Messages:
      (3,874)
    • Likes Received:
      (205)
    Might be time to start the looking process again. Disconnect the steering from the engine and see if it works like new. Might be the engine this time is sticking and not the cable.

    Then if it is the cable you might be getting a lot of salt water and you might have to replace it again.

    My guess would be the engine and not the cable.
     
  5. Bigfish69

    Bigfish69 Dirty Fisherman

    Location:
    Lakeside Ranch
    Name:
    JOHN
    Boat:
    Wellcraft V-20, 200 hp etec, 85' Holiday sportfisher
    • Messages:
      (4,248)
    • Likes Received:
      (0)
    Its a really basic system,,,only a few points where problems accur regularly. It sounds to me like your cable is still probably fine but your tilt tube is corroded. Look into replacing it. Thats waht steve did and it works and looks killer. I used to cheap out and pull the cable rod back out the tilt tube and lube the shaft really good with marine grade grease,,,the blue shit....stick it back in the hole really easy and oh baby back in business. Ooops allmost got nasty there for a minute. LOL

    Hope this helps Dude.

    69R
     
  6. mochosla

    mochosla Newbie

    Location:
    Granada Hills CA.
    Name:
    Carlos
    Boat:
    2000 21' WA Striper
    • Messages:
      (285)
    • Likes Received:
      (2)
    Yup, tilt tube corrosion. Is it a Force engine by any chance? Take the tube out and see the condition inside. Easy job.
     
  7. mandoman68

    mandoman68 Big Loco

    Location:
    Aztlan
    Name:
    Mandoman
    Boat:
    Kathleen
    • Messages:
      (627)
    • Likes Received:
      (215)
    69 merc 1000.
     
  8. mandoman68

    mandoman68 Big Loco

    Location:
    Aztlan
    Name:
    Mandoman
    Boat:
    Kathleen
    • Messages:
      (627)
    • Likes Received:
      (215)
    Thanks alot, guys. Really appriciated. Yes I have a sense of humor.
     
  9. ConSeaMate

    ConSeaMate Legend in my own mind

    Location:
    Escondido
    Name:
    Buster Brown
    Boat:
    28' Silverton "ConSeaMate"
    • Messages:
      (922,692)
    • Likes Received:
      (273)
    I'm mechanically inclined!..and a comedian......try shoving the cable up your ass to lube it........:hali_ruahahaha:.........
     
  10. mandoman68

    mandoman68 Big Loco

    Location:
    Aztlan
    Name:
    Mandoman
    Boat:
    Kathleen
    • Messages:
      (627)
    • Likes Received:
      (215)
    I would but your mom's tongue is in there right now. As soon as she is done liking my nuts I will try what you........................NAH, I'll just stick to your mom's tongue. Then I'll bend her over and show her my WARPDRIVE! You Anonymous Pussy. Oh and tell your wife not to kiss that dog.
     
  11. mandoman68

    mandoman68 Big Loco

    Location:
    Aztlan
    Name:
    Mandoman
    Boat:
    Kathleen
    • Messages:
      (627)
    • Likes Received:
      (215)
    Pissing off the world? Via the internet.Pussy
     
  12. Fishbones

    Fishbones Your wife thinks about ME

    Location:
    Chula Vista
    Name:
    Rich
    Boat:
    One Off 28' Custom Built Skipjack (SOUTHWESTERN) & 18' Sylvan (Short Runs)
    • Messages:
      (1,007,895)
    • Likes Received:
      (1,050)
    Could also be the pivot where the motor turns from port to starboard
     
  13. ConSeaMate

    ConSeaMate Legend in my own mind

    Location:
    Escondido
    Name:
    Buster Brown
    Boat:
    28' Silverton "ConSeaMate"
    • Messages:
      (922,692)
    • Likes Received:
      (273)
    Such anger?.....Don't have any friends to help you?......I can guess why......
     
  14. Ali

    Ali Master of Nothing Admin

    Location:
    San Diego
    Name:
    That Guy
    Boat:
    31' Innovator
    • Messages:
      (22,073)
    • Likes Received:
      (5,098)
    Hi,

    I'm here to ask for help and I'm a total dick to boot.

    Chill out Mandoman. This kinda crap is not needed on BD.

    Go fix your motor.
     
Thread Status:
Not open for further replies.

Share This Page